Biete Job - Update von 2.0.11 auf 2.1

Dieses Thema im Forum "Jobs und Angebote" wurde erstellt von argy, 22. März 2019.

  1. argy

    argy Aktives Mitglied Lizenzinhaber

    Hallo.

    Wir haben versucht das Update selbst zu machen (zum Glück erst mal nur auf einem Testsystem), leider ohne Erfolg.

    Das Update lief zwar durch, aber es werden diverse Fehler angezeigt, die Statistik ist leer (zeigt keine Werte an) und ich kann kein Zahnrädchen anklicken (um Einstellungen zu öffnen oder ein Addon zu deinstallieren) nach dem Update.

    Ich würde mich sehr freuen wenn sich ein erfahrener XF-Nutzer meldet der uns beim Update (gegen Bezahlung) helfen kann.

    Wir haben folgende Erweiterungen in der aktuellen 2.0.11 drin.
    [8WR] XenAtendo 2 (Calendar) PRO 2.0.1.6
    [AddonsLab] Navigation Badge 1.0.0
    [AddonsLab] Unread Post Count 1.4.0
    [TH] UI.X 2.0.8
    [XenDACH] Limit Language Usage 2.0.0
    [XFA] Core 1.1.2
    [XFA] Nodes Icon Tweak 3.0.0
    Editor & BB Code Manager 1.1.0
    Featured posts 1.6
    Keyword Management (KWM2) 1.2.0
    More threads 1.1
    Quick search 1.7
    Similar threads 4.1
    Staff activity 1.1
    Tapatalk 1.0.2
    XenForo Resource Manager 2.0.4

    Meldet euch einfach hier oder per PN.
    Vielen Dank

    PS: Wenn noch fragen sind, einfach her damit.
     
  2. Tealk

    Tealk Aktives Mitglied Lizenzinhaber

    Die Frage ist, möchtest du alle Add-ons behalten? Ich denke mal "Editor & BB Code Manager" wird durch 2.1 abgelöst? Und wegen KWM2, au lait ist ja aktuell unpässlich.
    Sind mir gerade nur mal so am ersten blick aufgefallen.
     
  3. argy

    argy Aktives Mitglied Lizenzinhaber

    Vom KWM 2 hab ich die 1.5.1 hier liegen welche auch für 2.1 ist.
    Editor & BB Code Manager könnte weg...
     
  4. mph

    mph Aktives Mitglied Lizenzinhaber

    Vielleicht solltest du auch die Fehlermeldungen beschreiben, sonst wird das Rätselraten hier.
     
  5. argy

    argy Aktives Mitglied Lizenzinhaber

    Das sind die angezeigten Fehler.
    Call to undefined method XFRM\Repository\ResourceItem::batchUpdateResourceViews()
      • src/addons/XFRM/Cron/Views.php:13
    Template error: Template public:setup_fa_variables.less is unknown
      • src/XF/Template/Templater.php:618
    Error rendering template public:core.less: variable @fa-var-caret-down is undefined in file public:core.less in public:core.less (on or near line 879)
      • src/XF/CssRenderException.php:87
    Error rendering template public:node_list.less: variable @fa-var-file-text is undefined in file public:node_list.less in public:node_list.less (on or near line 945)
      • src/XF/CssRenderException.php:87
    Error rendering template public:notices.less: variable @fa-var-remove is undefined in file public:notices.less in public:notices.less (on or near line 1108)
      • src/XF/CssRenderException.php:87
    Error rendering template public:app.less: variable @fa-var-caret-down is undefined in file public:app.less in public:app.less (on or near line 1324)
    • src/XF/CssRenderException.php:87
     
  6. McAtze

    McAtze Innendienst Lizenzinhaber

    Das sieht alles danach als wenn du FontAwesome Icons per EXTRA.less eingebunden hast und diese gibt es in der aktuellen FA Version nicht mehr. Hier solltest du einfach mal durchtesten: Font Awesome 5 Icons

    Du solltest vielleicht erstmal in der config.php die AddOns deaktivieren per:
    Code (Text):
    $config['enableListeners'] = false;
    Und anschließend kannst du die AddOns deinstallieren bzw. aktualisieren.
     
  7. argy

    argy Aktives Mitglied Lizenzinhaber

    file-text ist nun file-alt und remove ist nun times.
    Aber caret-down gibt es noch, daher ist es verwunderlich warum dies ebenfalls als Fehler interpretiert wird.

    Zumal ich soeben feststellen musste, dass ich den Code der Templates nicht aufrufen/sehen kann.
     

    Anhänge:

  8. McAtze

    McAtze Innendienst Lizenzinhaber

    Sehr kurios. Da ist wohl irgendwas beim Upgrade schief gelaufen. Hast du Fehlermeldungen während des Upgrades bekommen?
     
  9. argy

    argy Aktives Mitglied Lizenzinhaber

    Ein Kollege hat es durchgeführt aber mir ist nichts von Fehlermeldungen bekannt.
    Die Frage ist: ob und jemand helfen kann/möchte!?
     
  10. Masetrix

    Masetrix Aktives Mitglied Lizenzinhaber

    Da einzusteigen ist als xter nachträglich schwer und risikoreich. Ich kann hier nur empfehlen die addons, sowie die .less Inhalte zu deaktivieren und dann die weiteren Fehlermeldungen zu interpretieren. vielleicht läuft das Upgrade dann aber auch ohne weitere Fehler durch.

    Wie die Addons abgeschaltet werden steht ja bereits weiter oben. Bei den .less Templates am Anfang ein /* und am Ende ein */ setzen und abspeichern Das dürfte die daduch auftretenden Fehlermeldungen vermeiden. Da ihr klugerweise zuerst Tests in einer Testumgebung macht sollte es ein leichtes sein den ursprünglichen Zustand der Testumgebung wieder herzustellen, die Addons und lessdaten zu deaktivieren und das Upgrade erneut durchzuführen. Läuft das dann durch, die neueren Versionen der Addons installieren und alle .less Inhalte, die sich nicht auf FontAwesome beziehen testweise, nach und nach, wieder aktivieren...
     
    Zuletzt bearbeitet: 23. März 2019
    Alluidh gefällt das.
  11. argy

    argy Aktives Mitglied Lizenzinhaber

    Addons zu deaktivieren ist nicht das Problem. Leider bin ich kein Programmierer und kann daher mit den Fehlermeldungen teilweise nur sehr wenig anfangen.
    Für mich ist das eine Suche im Heuhaufen. ;-)
    Daher die Frage ob uns jemand (gegen Bezahlung) unterstützen kann.
    Derjenige erkennt dann eventuell eher woran es hängt bevor ich/wir uns einen Wolf suchen.
     
  12. Helga78

    Helga78 Aktives Mitglied Lizenzinhaber

    Wurde das nun gelöst?
     
  13. argy

    argy Aktives Mitglied Lizenzinhaber

    Sind dabei mit Hilfe von @Tealk das Update zu machen.
    Testforum wurde schon auf 2.1.1 geupdatet und die Addons auch.
    Die Tage wird das Template nochmal angepasst, da es in der alten Version zu viel Kauderwelsch gab.
    Das kann man sauberer machen.
     
    Masetrix gefällt das.
  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden